Skip to content

Compatibility & requirements

System Requirements

Operating Systems

FusionReactor is a Java agent (jar file) which contains most of the functionality and a native debugger library which provides the Event Snapshot, Debugger, and Heap Analysis features.

The Java agent will work on virtually any Java version on any operating system but some features may not be available; System Monitor and System CPU may be missing depending on the operating system's CPU.

Installer supports 64 bit operating systems

The traditional installer only support 64 bit operating systems.

Native debugger only supports amd64 and aarch64

The native debugger library only supports 64 bit operating systems on Windows and Mac OS and is only provided for aarch64 and amd64 processors on Linux operating systems.

Windows

  • Microsoft Windows Server 2022
  • Microsoft Windows Server 2019
  • Microsoft Windows Server 2016
  • Microsoft Windows Server 2012 R2
  • Microsoft Windows Server 2012
  • Microsoft Windows Server 2008 R2
  • Microsoft Windows Server 2008
  • Microsoft Windows 10
  • Microsoft Windows 8
  • Microsoft Windows 7

Linux

  • Red Hat Enterprise Linux 5 + Above
  • openSuse Linux 10.2 – 12.2
  • SuSE Linux Enterprise Server 8 + Above
  • Debian Linux 3 + Above
  • Oracle Linux 6 + Above
  • CentOS 6 + Above
  • Ubuntu 11 + Above
  • Kubuntu 9 + Above
  • Fedora 15 + Above

macOS

  • Apple macOS 12: "Monterey"
  • Apple macOS 11: "Big Sur"
  • Apple macOS 10.15: "Catalina"
  • Apple macOS 10.14: “Mojave”
  • Apple macOS 10.13: “High Sierra”
  • Apple macOS 10.12: “Sierra”
  • Apple macOS X 10.11: “El Capitan”
  • Apple macOS X 10.10: “Yosemite”

Debug library not supported on M1 chipset

If you are running on the new Apple M1 chipset, the debugger library is currently not supported and the JVM arg must be removed

Java

  • Oracle Java 7 – 17
  • Open JDK 8
  • Open JDK 10 – 17
  • Liberica JDK 8, 11, 16
  • Amazon Corretto 8, 11, 17
  • Azul Zulu 11, 17

Java 6 support removed

Java 6 support was discontinued with FusionReactor 8.3.0. If you need to use Java 6 we recommend you stay with version 8.2.3.

Servers

J2EE / Other Servers

  • Apache Tomcat 7 – 10
  • JBoss AS 6 / 7
  • WildFly 8 – 26
  • Jetty 7 – 11
  • GlassFish 4 / 5
  • Payara 5
  • ColdFusion

ColdFusion Servers

  • Adobe ColdFusion 2021
  • Adobe ColdFusion 2018
  • Adobe ColdFusion 2016
  • Adobe ColdFusion 11
  • Adobe ColdFusion 10
  • Lucee 4.5.x
  • Lucee 5.x

Note

Some older versions of Lucee 5 have known issues.

Manual install only for WebSphere & WebLogic

WebSphere and WebLogic servers work in most configurations but are not supported by Installer / FRAM. Users must follow the manual installation steps.

Browsers


Chrome 21+

Firefox 20+

Safari

Windows: Safari 5.1.7+
Mac OSX: Safari 5.1.9+

Microsoft Edge

Internet Explorer support removed

Due to security concerns Internet Explorer support was removed in FusionReactor 8.5.0 and above. You will now see a blank page when attempting to load the FusionReactor UI.


Need more help?

Contact support in the chat bubble and let us know how we can assist.